在线检测未来函数

通达信黄金分割线分时主图必赢国际娱乐官网公式

来源:Internet,编辑:股旁网,2017-03-17

{分时均线}
W:=BARSLAST(DAY-REF(DAY,1))+1;
FSJX:SUM(C*VOL,W)/SUM(VOL,W),COLORYELLOW,LINETHICK2; IF(FSJX<REF(FSJX,1),FSJX,DRAWNULL),COLORCYAN,LINETHICK2;
{分时线}
FSX:IF(C>=FSJX,C,DRAWNULL),COLORRED,LINETHICK2; IF(C<FSJX,C,DRAWNULL),COLORCYAN,LINETHICK2;
{黄金分割线,4*60'=240'}
HH:=CONST(HHV(C,0));
LL:=CONST(LLV(C,0));
HL:=HH-LL;
顶:HH,COLORCYAN,LINETHICK1;
A809:0.809*HL+LL,COLORFFFF0B,DOTLINE;
A618:0.618*HL+LL,COLORLIGRAY,DOTLINE;
A500:0.500*HL+LL,COLOR80FFFF,DOTLINE;
A382:0.382*HL+LL,COLORLIGRAY,DOTLINE;
A191:0.191*HL+LL,COLOR00FF00,DOTLINE;
底:LL,COLOR00FF00,LINETHICK1;
DRAWICON(C=LL,LL,9);
{黄金线240分钟静态提示}
DRAWTEXT(CURRBARSCOUNT=240,HH,'顶'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=240,A809,'809'),COLORFFFF0B;
DRAWTEXT(CURRBARSCOUNT=240,A618,'618'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=240,A500,'500'),COLOR80FFFF;
DRAWTEXT(CURRBARSCOUNT=240,A382,'382'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=240,A191,'191'),COLOR60FF60;
DRAWTEXT(CURRBARSCOUNT=240,LL,'底'),COLOR60FF60;
{黄金线1分钟动态提示}
DRAWTEXT(CURRBARSCOUNT=1,HH,'顶危'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,A809,'809警'),COLORFFFF0B;
DRAWTEXT(CURRBARSCOUNT=1,A618,'618警'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,A500,'500警'),COLOR80FFFF;
DRAWTEXT(CURRBARSCOUNT=1,A382,'382警'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,A191,'191警'),COLOR60FF60;
DRAWTEXT(CURRBARSCOUNT=1,LL,'底安'),COLOR60FF60;
{常规提示}
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.04,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.08,0,FGBLOCK),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.12,0,'公告不冲动'),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.06,0.12,0,'竞价不可信'),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.12,0.12,0,'纠错不犹豫'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.16,0,'涨停不躁动'),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.06,0.16,0,'跌底果断进'),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.12,0.16,0,'涨顶坚决出'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.20,0,'黄金高不买'),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.06,0.20,0,'黄金跌不买'),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.12,0.20,0,'黄金弹不买'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.24,0,'分时线:红 FSJX撑涨 青 FSJX压跌'),COLORYELLOW;

通达信黄金分割线分时主图必赢国际娱乐官网公式

 

相关文章

博聚网