在线检测未来函数

通达信股民上班主图必赢国际娱乐官网公式

来源:Internet,编辑:股旁网,2017-11-08

DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.009,'↓←减') , COLORGREEN,LINETHICK1;
K1:EMA(C,5),COLOR00AA00;
K2:EMA(C,10),COLOR00AA00;
K3:EMA(C,15),COLOR00AA00;
K4:EMA(C,20) ,COLOR00AA00;
K5:EMA(C,35) ,COLOR0000FF;
K6:EMA(C,41) ,COLOR0000FF;
K7:EMA(C,47) ,COLOR0000FF;
K8:EMA(C,53) ,COLOR0000FF;
K9:EMA(C,65) ,COLORYELLOW;
K10:EMA(C,75) ,COLORYELLOW;
K11:EMA(C,85) ,COLORYELLOW;
K12:EMA(C,95),COLORYELLOW;
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,20)*(1+80/1000),POINTDOT,COLORGREEN,LINETHICK3;
买入:=XMA(VAR1,32)*(1-100/1000),POINTDOT,COLORMAGENTA,LINETHICK3;
幅度:=100*(卖出-买入)/买入,NODRAW;
菩提:=买入+(卖出-买入)*2/3;{此函数仅做参考线,为提前趋势预测线,上涨途中向下见顶,下跌途中向上见底};
般:=XMA(CLOSE,7);
若:=MEMA(CLOSE,3);
全绿K:=LONGCROSS(若,般,3) AND H>菩提;
RSVL:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
KL:=SMA(RSVL,3,1);
DL:=SMA(KL,3,1);
KKL:=SMA(RSVL,3,1);
DD:=SMA(KL,3,1);
NL:=KKL+DD;
买入L:=DRAWICON(CROSS(NL,50),50,1),COLORRED;
卖出L:=DRAWICON(CROSS(160,NL),160,2),COLORGREEN;
卖出K:=CROSS(160,NL);
TM:=(CLOSE*1.0+LOW*0.0+HIGH*0.0);
T1M:=V;
SL1M:=(TM/REF(TM,1)-1)*1000;
趋势5:=XMA(XMA(XMA(SL1M,20),20),20),COLORYELLOW;
趋势6:=XMA(XMA(XMA(SL1M,10),10),10),COLORMAGENTA;
QA9:=趋势6-趋势5;
QA10:=EMA(QA9,89);
买入M:=(QA9-QA10)*2,COLORSTICK;
M1:=EMA(C,5);M2:=EMA(C,13);M3:=EMA(C,34),COLORBLUE,LINETHICK2;
MC1:=EMA(C,55);MC2:=EMA(C,89);MA4:=EMA(C,144);
VAR1A1H:=(REF(CLOSE,1)-REF(ATR,1));
买线1:=REF(EMA(C,14),1)COLORWHITE,LINETHICK3;
卖线1:=IF(MC1>MAX(MC2,MA4),MC1,IF(MC1<MIN(MC2,MA4),MC2,MA4)),COLORFF00CC,LINETHICK3;
高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
STICKLINE(买线1>=卖线1,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,6,0)COLOR001050;
STICKLINE(买线1<卖线1,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,6,0)COLOR404050;
STICKLINE(买入M>=0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORRED;
STICKLINE(买入M<0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORGREEN;
STICKLINE(买入L,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,2,0)COLORYELLOW;
STICKLINE(卖出K AND 买入M<0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.96,2,0)COLORCYAN;
VAR01:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);{ZIG 有未来}
VAR2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
STICKLINE(VAR2,H,L,1,0),COLORFF00FF,LINETHICK1;{底位红色};

通达信股民上班主图必赢国际娱乐官网公式

 

相关文章

博聚网