在线检测未来函数

N天前跌幅公式

来源:Internet,编辑:股旁网,2017-11-30

编写要求:

如 3日前跌幅-8 2日前涨幅+3 1日前跌幅-1 这三日跌幅是-6 要求今日涨跌幅不算

股旁网解答:

DF:=(C-REF(C,1))/REF(C,1)*100;{涨跌幅}
R1:=REF(DF,1)<-1;{昨天涨跌}
R2:=REF(DF,2)>3;{前天涨跌}
R3:=REF(DF,3)<-8;{大前天涨跌}
T3:=(REF(C,1)-REF(C,3))/REF(C,3)*100;{前三天的涨跌}
N:=-10;{前三天总跌幅、自己调整}
XG:R1 AND R2 AND R3 AND T3>N;

相关文章

博聚网