在线检测未来函数

通达信多空趋势带主图必赢国际娱乐官网公式

来源:Internet,编辑:股旁网,2017-12-04

工作线:(EMA(C,14)),LINETHICK2,COLORYELLOW;
生命线:(MA(C,25)) ,LINETHICK1,COLORMAGENTA;
高:= HHV(EMA(EMA(EMA(EMA(EMA(L,2),2),2),2),2),2),COLORLIBLUE,LINETHICK1;
低:= LLV(EMA(EMA(EMA(EMA(EMA(L,2),2),2),2),2),1),COLORRED,LINETHICK2;
{30分钟MA}
MA4:=MA(C,4),COLORBLUE,LINETHICK4;
A8:=MA(C,8),COLORRED;
A24:=MA(C,24),COLORRED;
A40:=MA(C,40);
A80:=MA(C,80);
A160:=MA(C,160);
DK:=A8;
买:=IF(MA4>REF(MA4,1),MA4,DRAWNULL),COLORRED,LINETHICK4;
卖:=IF(MA4<REF(MA4,1),MA4,DRAWNULL),COLORGREEN,LINETHICK4;
牛熊分界线:=EMA(CLOSE,50),LINETHICK1,COLORRED;
{NO.2}
VAR31:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR41:=(20*VAR31+19*REF(VAR31,1)+18*REF(VAR31,2)+17*REF(VAR31,3)+16*REF(VAR31,4)+15*REF(VAR31,5)+14*REF(VAR31,6)+13*REF(VAR31,7)+12*REF(VAR31,8)+11*REF(VAR31,9)+10*REF(VAR31,10)+9*REF(VAR31,11)+8*REF(VAR31,12)+7*REF(VAR31,13)+6*REF(VAR31,14)+5*REF(VAR31,15)+4*REF(VAR31,16)+3*REF(VAR31,17)+2*REF(VAR31,18)+REF(VAR31,20))/210,COLORRED;
VAR51:=MA(VAR41,6),COLORGREEN;
DRAWBAND(VAR41,RGB(155,50,50),VAR51,RGB(0,100,50));
红线:VAR41,COLORRED;
绿线:VAR51,COLORGREEN;
X1:=(C+L+H)/1.5;
X2:=EMA(X1,3);
X3:=EMA(X2,2.5);
DIFF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIFF1,9);
CBFB:=COSTEX(C,REF(C,1));
JL:=IF(C>CBFB,V,0);
CL:=IF(C<CBFB,V,0);
JLH:=SUM(JL,4);
CLH:=SUM(CL,4);
LHB:=CLH/JLH;
TJ1:=IF(HHV(LHB,5)>4 AND CROSS(2,LHB) AND C>=O,1,0);
VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR9:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR11:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5<REF(VAR5,1);
VAR14:=L<HHV(H,60)*0.6 OR L<HHV(H,50)*0.65 OR L<HHV(H,40)*0.7 OR L<HHV(H,30)*0.75 OR L<HHV(H,20)*0.8
OR L<HHV(H,10)*0.85
AND (H-L)/REF(C,1)>0.08
AND V>MA(V,135)
AND VAR2<40
AND VAR5>REF(VAR5,1);
VAR15:=H<MA(C,20) OR CROSS(MA(C,5),MA(C,10));
VAR16:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),26)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),26)*100<40
OR 100*((SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),26))*2+(SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26)))/((SUM(IF(CLOSE<REF(CLOSE,1),
VOL,0),26))*2+(SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26)))<40
OR SUM(MAX(0,HIGH-REF(CLOSE,1)),26)/SUM(MAX(0,REF(CLOSE,1)-LOW),26)*100<40
OR SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100<40;
VAR17:=CROSS(82,SMA(MAX(C-(REF(C,1)),0),6,1)/SMA(ABS(C-(REF(C,1))),6,1)*100);
VAR18:=CROSS((SMA(MAX(CLOSE-(REF(CLOSE,1)),0),6,1)/SMA(ABS(CLOSE-(REF(CLOSE,1))),6,1)*100),20);
EMA7:=EMA(C,7),COLOR00FF00;
EMA14:=EMA(C,14),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
ZMA7:=EMA(C,35),COLORFF00FF;
ZMA14:=EMA(C,70),COLORFFCCCC;
ZMA34:=EMA(C,170),COLORFFCC66;
VV1:=EMA(C,35)>EMA(C,70) AND EMA(C,35)>EMA(C,170) AND EMA(C,170)>REF(EMA(C,170),1);
VV2:=VV1 AND CROSS(EMA(C,70),EMA(C,170));
RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K11:=SMA(RSV1,5,1);
D11:=SMA(K11,5,1);
J11:=3*K11-2*D11;
AA11:=EMA(J11,5);
AA22:=REF(AA11,1);
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K22:=SMA(RSV2,3,1);
D22:=SMA(K22,3,1);
J22:=3*K22-2*D22;
BB11:=EMA(J22,5);
BB22:=REF(BB11,1);
DD:=AA11>AA22 AND BB11>BB22;
注意买入:=DD AND NOT(REF(DD,1)) AND (AA11<50 OR BB11<50);
注意卖出:=REF(DD,1)=1 AND NOT(DD);
VAR1A:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,9);
VAR2A:=REF(VAR1A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3A:=REF(VAR2A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4A:=REF(VAR3A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5A:=REF(VAR4A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6A:=REF(VAR5A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7A:=REF(VAR6A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8A:=REF(VAR7A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9A:=REF(VAR8A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARAA:=REF(VAR9A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARBA:=REF(VARAA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARCA:=REF(VARBA,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARDA:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VAREA:=REF(VARDA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARFA:=REF(VAREA,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10A:=REF(VARFA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11A:=REF(VAR10A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12A:=REF(VAR11A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13A:=REF(VAR12A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14A:=REF(VAR13A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15A:=REF(VAR14A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16A:=REF(VAR15A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17A:=REF(VAR16A,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18A:=REF(VAR17A,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19A:=REF(VARDA OR VAREA OR VARFA OR VAR10A OR VAR11A OR VAR12A OR VAR13A OR
VAR14A OR VAR15A OR VAR16A OR VAR17A OR VAR18A,1) AND VAR1A;
MA1V:=MA(C,6),COLORRED;
AV:=C-MA1V;
A1V:=CROSS(AV,0);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
VAR20:=LLV(LOW,10);
VAR21:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-VAR20)/(VAR21-VAR20),4);
STICKLINE(DK<=C AND CLOSE>=OPEN,HIGH,LOW,0,1),COLORRED;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,3.2,0),COLOR6600FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,2.7,0),COLORDD33FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,2.1,0),COLORFF55FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,1.5,0),COLORFF88FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,0.9,0),COLORFFAAFF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,0.3,0),COLORFFCCFF;
STICKLINE(DK<=C AND CLOSE<OPEN,HIGH,LOW,0,1),COLORRED;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,3.2,0),COLOR000033;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,2.7,0),COLOR000066;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,2.1,0),COLOR000099;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,0.9,0),COLOR0000FF;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,0.3,0),COLORCC66FF;
STICKLINE(DK>C AND CLOSE>=OPEN,HIGH,LOW,0,1),COLORGREEN;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,3.2,0 ),COLOR990000;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,2.7,0 ),COLORCC0000;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,2.1,0),COLORFF4400;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,1.5,0 ),COLORFF8800;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,0.9,0 ),COLORFFCC00;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,0.3,0 ),COLORCYAN;
STICKLINE(DK>C AND CLOSE<OPEN,HIGH,LOW,0,1),COLORWHITE;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,3.2,0 ),COLOR555555;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,2.7,0 ),COLOR777777;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,2.1,0 ),COLOR999999;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,1.5,0 ),COLOR999999;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,0.9,0 ),COLORDDDDDD;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,0.3,0 ),COLORFFFFFF;

通达信多空趋势带主图必赢国际娱乐官网公式

 

相关文章

博聚网